Google Cloud Platform products experiencing Service issues

Incident Report for MyVenue Status Page

Postmortem

The issue affecting both Google Cloud and Amazon Web Services (AWS), which are critical parts of our infrastructure have now been resolved with the full resumption of services.

We recommend restarting POS devices as a precautionary measure. This is because when the Firebase connection is lost, a manual reboot manually reconnects and ensures the connection is reestablished.

Posted Jun 12, 2025 - 21:36 UTC

Resolved

Widesread outages affecting both Google Cloud and Amazon Web Services (AWS), which are critical parts of our infrastructure have begun to stabilize.

This began at approximately 2:06 PM EDT, June 12, 2025 and is impacting some functionality within mvManager. Since the last update, systems are recovering and are now back online within mvManager. However, for mvPOS, we recommend restarting the POS device as a precautionary measure. This is because when the Firebase connection is lost, a manual reboot manually reconnects and ensures the connection is reestablished.

We recommend POS terminals operate in offline/airplane mode until the issue is resolved & rebooting the POS terminals.
Credit cards will be able to be processed in offline mode.
Posted Jun 12, 2025 - 20:58 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 12, 2025 - 19:47 UTC

Monitoring

We a currently experiencing a service disruption due to a widespread outage affecting Google Cloud services, which are a core part of our infrastructure.

This began at approximately 2:06 PM EDT, June 12, 2025 and is impacting some functionality within our mvManager and the processing of credit cards.

We are actively monitoring the situation and working to minimize impact where possible. The issue originates from Google and is being addressed on their end.

We will provide updates every 30 minutes or as new information becomes available.

We recommend POS terminals operate in offline until the Google issue is resolved.
Posted Jun 12, 2025 - 19:47 UTC
This incident affected: Credit Card Processing and Integrations.