We are currently processing sales in real time and continue to closely monitor the impact of the outage. Our systems remain stable, and we are sustaining uptime across all key services.
Key points:
Sales operations are functioning normally with no current delays. Monitoring tools are actively tracking system performance and customer impact. Engineering teams remain on standby to respond to any anomalies.
We will provide further updates as needed or if there are any changes in system status.
Posted Oct 20, 2025 - 11:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 10:15 UTC
Identified
We are aware of an ongoing global outage affecting Amazon Web Services. This is currently causing delays in certain components within mvManager.
All core POS operations remain functional.
We are actively monitoring the situation and will provide updates as AWS implements recovery actions.
Posted Oct 20, 2025 - 10:03 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:55 UTC
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:54 UTC
Investigating
We are aware of an ongoing global outage affecting Amazon Web Services (AWS). This may be causing intermittent delays or disruptions to certain sales transaction data flows into mvManager.
Posted Oct 20, 2025 - 09:47 UTC
This incident affects: Integrations, Back Office Reports, Real Time Updates, and Real Time Sales Processing.